<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />

<title>Breakfast Club Cruise-in - Park Labrea News/ Beverly PressPark Labrea News/ Beverly Press</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="https://beverlypress.com/wp-content/themes/jupiter/style.css" />
<link rel="pingback" href="https://beverlypress.com/xmlrpc.php" />


<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://beverlypress.com/2021/03/breakfast-club-cruise-in/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Breakfast Club Cruise-in - Park Labrea News/ Beverly Press" />
	<meta property="og:description" content="Don’t miss the March Breakfast Club Cruise-in with the Petersen Automotive Museum on Sunday, March 28, from 8..." />
	<meta property="og:url" content="https://beverlypress.com/2021/03/breakfast-club-cruise-in/" />
	<meta property="og:site_name" content="Park Labrea News/ Beverly Press" />
	<meta property="article:published_time" content="2021-03-25T20:30:42+00:00" />
	<meta property="og:image" content="https://beverlypress.com/wp-content/uploads/2021/03/Cal.Petersen.CruiseIn.png" />
	<meta property="og:image:width" content="333" />
	<meta property="og:image:height" content="419" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Edwin Folven">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://beverlypress.com/#website","url":"https://beverlypress.com/","name":"Park Labrea News/ Beverly Press","description":"Park Labrea News and Beverly Press","potentialAction":[{"@type":"SearchAction","target":"https://beverlypress.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/#primaryimage","inLanguage":"en-US","url":"https://beverlypress.com/wp-content/uploads/2021/03/Cal.Petersen.CruiseIn.png","width":333,"height":419},{"@type":"WebPage","@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/#webpage","url":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/","name":"Breakfast Club Cruise-in - Park Labrea News/ Beverly Press","isPartOf":{"@id":"https://beverlypress.com/#website"},"primaryImageOfPage":{"@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/#primaryimage"},"datePublished":"2021-03-25T20:30:42+00:00","dateModified":"2021-03-25T20:30:42+00:00","author":{"@id":"https://beverlypress.com/#/schema/person/f03cb66c6437341514f546a8bac2ac13"},"breadcrumb":{"@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://beverlypress.com/2021/03/breakfast-club-cruise-in/"]}]},{"@type":"BreadcrumbList","@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://beverlypress.com/","url":"https://beverlypress.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/","url":"https://beverlypress.com/2021/03/breakfast-club-cruise-in/","name":"Breakfast Club Cruise-in"}}]},{"@type":"Person","@id":"https://beverlypress.com/#/schema/person/f03cb66c6437341514f546a8bac2ac13","name":"Edwin Folven","image":{"@type":"ImageObject","@id":"https://beverlypress.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7b1396b37dd6989702b66d85a9803e21?s=96&d=mm&r=g","caption":"Edwin Folven"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Park Labrea News/ Beverly Press &raquo; Feed" href="https://beverlypress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Park Labrea News/ Beverly Press &raquo; Comments Feed" href="https://beverlypress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Park Labrea News/ Beverly Press &raquo; Breakfast Club Cruise-in Comments Feed" href="https://beverlypress.com/2021/03/breakfast-club-cruise-in/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/beverlypress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=67ec925be406469c010e4e6f6a53f49d"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='colorbox-css'  href='https://beverlypress.com/wp-content/plugins/wp-colorbox/example5/colorbox.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://beverlypress.com/wp-includes/css/dist/block-library/style.min.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<link rel='stylesheet' id='agp-core-repeater-css-css'  href='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/repeater/css/style.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<link rel='stylesheet' id='fac-css-css'  href='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/css/style.min.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://beverlypress.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://beverlypress.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://beverlypress.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=1.5.70' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_googlefonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu&#038;subset=greek,latin,greek-ext,vietnamese,cyrillic-ext,latin-ext,cyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://beverlypress.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=1.5.70' type='text/css' media='all' />
<link rel='stylesheet' id='default-css'  href='https://beverlypress.com/wp-content/themes/jupiter/style.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<link rel='stylesheet' id='jqueryui-css'  href='https://beverlypress.com/wp-content/themes/jupiter/css/jqueryui/custom.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='tipsy-css'  href='https://beverlypress.com/wp-content/themes/jupiter/css/tipsy.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://beverlypress.com/wp-content/themes/jupiter/js/fancybox/jquery.fancybox.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://beverlypress.com/wp-content/themes/jupiter/js/flexslider/flexslider.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://beverlypress.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='swipebox-css'  href='https://beverlypress.com/wp-content/themes/jupiter/js/swipebox.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='screen-css'  href='https://beverlypress.com/wp-content/themes/jupiter/css/screen.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='custom_css-css'  href='https://beverlypress.com/wp-content/themes/jupiter/templates/custom-css.php?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='grid-css-css'  href='https://beverlypress.com/wp-content/themes/jupiter/css/grid.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://beverlypress.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://beverlypress.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/enable-jquery-migrate-helperBAK/js/jquery/jquery-1.12.4-wp.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/enable-jquery-migrate-helperBAK/js/jquery-migrate/jquery-migrate-1.4.1-wp.js?ver=1.4.1-wp' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/wp-colorbox/jquery.colorbox-min.js?ver=1.1.4' id='colorbox-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/wp-colorbox/wp-colorbox.js?ver=1.1.4' id='wp-colorbox-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/repeater/js/main.js?ver=67ec925be406469c010e4e6f6a53f49d' id='agp-core-repeater-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/libs/jquery.mobile.min.js?ver=67ec925be406469c010e4e6f6a53f49d' id='fac-mobile-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/libs/responsiveslides.min.js?ver=67ec925be406469c010e4e6f6a53f49d' id='fac-slider-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/assets/js/main.min.js?ver=67ec925be406469c010e4e6f6a53f49d' id='fac-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/flowpaper-lite-pdf-flipbook/assets/lity/lity.min.js' id='lity-js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3' id='sumoselect-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.4.5' id='jquery-mobile-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.5.70' id='mCustomScrollbar-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1' id='jquery-fullscreen-js'></script>
<script type='text/javascript' id='bwg_frontend-js-extra'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/beverlypress.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=1.5.70' id='bwg_frontend-js'></script>
<link rel="https://api.w.org/" href="https://beverlypress.com/wp-json/" /><link rel="alternate" type="application/json" href="https://beverlypress.com/wp-json/wp/v2/posts/77946" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beverlypress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beverlypress.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://beverlypress.com/?p=77946' />
<link rel="alternate" type="application/json+oembed" href="https://beverlypress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://beverlypress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_color_main="D7E5ED";a2a_color_border="AECADB";a2a_color_link_text="0654c1";a2a_color_link_text_hover="333333";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//beverlypress.com/?wordfence_lh=1&hid=29C8456EF8EB140AD64EFB330257803C');
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	 


</head>

<body class="post-template-default single single-post postid-77946 single-format-standard custom-background">
		<input type="hidden" id="pp_ajax_search" name="pp_ajax_search" value=""/>
	<input type="hidden" id="pp_homepage_url" name="pp_homepage_url" value="https://beverlypress.com"/>
		<input type="hidden" id="pp_slider_auto" name="pp_slider_auto" value="true"/>
		<input type="hidden" id="pp_slider_timer" name="pp_slider_timer" value="8"/>
	
	<!-- Begin mobile menu -->
	<div class="mobile_menu_wrapper">
	    <div class="menu-top-menu-container"><ul id="mobile_main_menu" class="mobile_main_nav"><li id="menu-item-29093" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-29093"><a href="https://beverlypress.com"><i class="fa fa-home"></i></a></li>
<li id="menu-item-29091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29091"><a href="https://beverlypress.com/advertising/">Advertising</a></li>
<li id="menu-item-29090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29090"><a href="https://beverlypress.com/subscriptions/">Subscriptions</a></li>
<li id="menu-item-29088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29088"><a href="https://beverlypress.com/contact-us/">Contact</a></li>
<li id="menu-item-29089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29089"><a href="https://beverlypress.com/about-us/">About</a></li>
<li id="menu-item-30005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30005"><a href="https://beverlypress.com/archives/">Archives</a></li>
<li id="menu-item-30657" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-30657"><a href="https://beverlypress.com/category/calendar/"><i class="fa fa-calendar"></i></a></li>
</ul></div><div class="menu-main-menu-container"><ul id="mobile_second_menu" class="mobile_main_nav"><li id="menu-item-29099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29099"><a href="https://beverlypress.com/category/local_news/">News</a></li>
<li id="menu-item-29096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29096"><a href="https://beverlypress.com/category/crime/">Crime</a></li>
<li id="menu-item-29097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29097"><a href="https://beverlypress.com/category/dining-and-entertainment/">Dining &#038; Entertainment</a></li>
<li id="menu-item-29098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29098"><a href="https://beverlypress.com/category/life-style-and-art/">Life, Style &#038; Art</a></li>
<li id="menu-item-31947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31947"><a href="https://beverlypress.com/category/schools/">Schools</a></li>
<li id="menu-item-53252" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-53252"><a href="https://beverlypress.com/category/calendar/">Calendar</a></li>
<li id="menu-item-50402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50402"><a href="https://beverlypress.com/category/letters-to-the-editor/">Letters</a></li>
</ul></div>	</div>
	<!-- End mobile menu -->
	
	<!-- Begin template wrapper -->
	<div id="wrapper">
	
		<!-- Begin header -->
		<div id="header_wrapper">
			<div class="standard_wrapper">
				<div id="mobile_nav_icon"></div>
				<div class="menu-top-menu-container"><ul id="main_menu" class="main_nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-29093"><a href="https://beverlypress.com"><i class="fa fa-home"></i></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29091"><a href="https://beverlypress.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29090"><a href="https://beverlypress.com/subscriptions/">Subscriptions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29088"><a href="https://beverlypress.com/contact-us/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29089"><a href="https://beverlypress.com/about-us/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30005"><a href="https://beverlypress.com/archives/">Archives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-30657"><a href="https://beverlypress.com/category/calendar/"><i class="fa fa-calendar"></i></a></li>
</ul></div>				<div id="menu_border_wrapper"></div>
				<form role="search" method="get" name="searchform" id="searchform" action="https://beverlypress.com/">
					<div>
						<input type="text" value="" name="s" id="s" autocomplete="off" title="Search..."/>
						<button type="submit">
					    	<img src="https://beverlypress.com/wp-content/themes/jupiter/images/search_form_icon.png" alt=""/>
					    </button>
					</div>
				    <div id="autocomplete"></div>
				</form>
				<div class="social_wrapper">
    <ul>
    	    	    	<li class="twitter"><a target="_blank" title="Twitter" href="http://twitter.com/BeverlyPress"><img src="https://beverlypress.com/wp-content/themes/jupiter/images/social_black/twitter.png" alt=""/></a></li>
    	    	    	    	    	    	    	    	    	            </ul>
</div>			</div>
		</div>
		<!-- End header -->
		
		<div class="header_ads fade-in animated1">
		    		</div>
		
		<div id="boxed_wrapper">
			<div class="logo fade-in animated1">
				<div class="download-issue">
				
																	
							<a href="https://beverlypress.com/wp-content/uploads/2021/03/3.25-issue-1.pdf">
								<img src="https://beverlypress.com/wp-content/themes/jupiter/images/download-issue.jpg" alt="Download Newspaper Issue" />
								<p>Download Latest Issue</p>
							</a>
						
															
				<!--/download-issue--></div>
				<!-- Begin logo -->	
						
					<a id="custom_logo" class="logo_wrapper" href="https://beverlypress.com">
						<img src="https://beverlypress.com/wp-content/uploads/2018/06/park-labrea-news-beverly-press-low.png" alt=""/>
					</a>

								<!-- End logo -->
				
				<div class="header-ad">
				
					<div><div class="dfad dfad_pos_1 dfad_first" id="_ad_29917"><a href="https://issuu.com/beverlypress/docs/see-sip-savor-2019?fr=sY2RlNTI5MTQ3Ng" target="_blank"><img src="https://beverlypress.com/wp-content/uploads/2019/09/see-sip-savor-2019-header-1.png" alt="header-right" width="200" height="auto" class="aligncenter size-full wp-image-52633" /></a></div></div>				
				<!--/header-ad--></div>
				
			</div>
			
			<div class="menu-main-menu-container"><ul id="second_menu" class="second_nav fade-in animated1"><li id="menu-item-29099" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/local_news/">News</a></li>
<li id="menu-item-29096" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/crime/">Crime</a></li>
<li id="menu-item-29097" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/dining-and-entertainment/">Dining &#038; Entertainment</a></li>
<li id="menu-item-29098" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/life-style-and-art/">Life, Style &#038; Art</a></li>
<li id="menu-item-31947" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/schools/">Schools</a></li>
<li id="menu-item-53252" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://beverlypress.com/category/calendar/">Calendar</a></li>
<li id="menu-item-50402" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://beverlypress.com/category/letters-to-the-editor/">Letters</a></li>
</ul></div>		</div>
<div class="header-leaderboard">
	
	<!--homepage ad-->

		
		<div id="dfUiPpo" class="dfads-javascript-load"></div>
		<script>
		(function($) { 
			$("#dfUiPpo").load("https://beverlypress.com/wp-admin/admin-ajax.php?action=dfads_ajax_load_ads&groups=9833&limit=1&orderby=random&order=ASC&container_id=&container_html=none&container_class=&ad_html=div&ad_class=&callback_function=&return_javascript=0&_block_id=dfUiPpo" );			
		})( jQuery );
		</script>
		<noscript><div class="dfad dfad_pos_1 dfad_first" id="_ad_74777"><a href="https://www.immaculateheart.org"><img src="https://beverlypress.com/wp-content/uploads/2020/12/ImmaculateHeart.leaderboard.DEC2020.jpg" alt="" width="728" height="90" class="aligncenter size-full wp-image-74778" /></a></div></noscript>
		
	
<!--/header-leaderboard--></div>

<div id="page_caption" class="single_post fade-in animated2">
	<div class="boxed_wrapper">
		
		<div class="sub_page_caption">
										 
	    	
	    	March 25, 2021</div>
		<h2>Breakfast Club Cruise-in</h2>
	</div>
</div>
<div class="single_post_ft_wrapper  fade-in animated3">
	</div>
<!-- Begin content -->
<div id="content_wrapper">
    <div class="inner">
    	<!-- Begin main content -->
    	<div class="inner_wrapper">
    		<div class="sidebar_content fade-in animated4">		
										<!-- Begin each blog post -->
						<div class="post_wrapper" style="padding-top:0;">
							<div class="post_inner_wrapper">
						    	<div class="post_wrapper_inner">
									<div class="post_inner_wrapper">
								        
										<p><img loading="lazy" class="aligncenter size-full wp-image-77947" src="https://beverlypress.com/wp-content/uploads/2021/03/Cal.Petersen.CruiseIn.png" alt="" width="333" height="419">Don’t miss the March Breakfast Club Cruise-in with the Petersen Automotive Museum on Sunday, March 28, from 8 to 11 a.m. The museum will host a morning of conversation and cars and owners can bring their vehicles for display. All vehicles and spectators must be pre-registered to participate. 6060 Wilshire Blvd. (323)930-2277, petersen.org.</p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://beverlypress.com/2021/03/breakfast-club-cruise-in/" data-a2a-title="Breakfast Club Cruise-in"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&amp;linkname=Breakfast%20Club%20Cruise-in" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&amp;linkname=Breakfast%20Club%20Cruise-in" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&amp;linkname=Breakfast%20Club%20Cruise-in" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&amp;linkname=Breakfast%20Club%20Cruise-in" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fbeverlypress.com%2F2021%2F03%2Fbreakfast-club-cruise-in%2F&amp;linkname=Breakfast%20Club%20Cruise-in" title="Email" rel="nofollow noopener" target="_blank"></a></div></div>										
																				
										<br class="clear"/><br/>
																				
									</div>
									
								</div>
								<!-- End each blog post -->
						</div>
						
						<br class="clear"/><hr class="thick"/><br class="clear"/>						    
						    						    	  	<div class="post_previous">
						    	  		<span class="post_previous_icon"></span>
						    	  		<div class="post_previous_content">
						    	  			<h6>Previous Post</h6>
						    	  			<a href="https://beverlypress.com/2021/03/sundays-live-at-lacma/">Sundays Live at LACMA</a>
						    	  		</div>
						    	  	</div>
						    						    
						    						    	  	<div class="post_next">
						    	  		<span class="post_next_icon"></span>
						    	  		<div class="post_next_content">
						    	  			<h6>Next Post</h6>
						    	  			<a href="https://beverlypress.com/2021/03/how-to-create-a-solo-show/">How to create a solo show</a>
						    	  		</div>
						    	  	</div>
						    						
						<br class="clear"/><br class="clear"/><br class="clear"/>
						<div class="post_wrapper" style="padding-top:0">
							<div class="post_wrapper_inner">
																
																
								<br class="clear"/><h5 class="header_line subtitle"><span>You might also like</span></h5><br class="clear"/>								  
								 	<div class="flexslider post_carousel">
								 		<ul class="slides">
								  
										 										    <li>
										    											    		<a href="https://beverlypress.com/2021/03/petersen-honors-italian-automotive-designer/" title="Petersen honors Italian automotive designer"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2021/03/Petersen.PininfarinaExhibit-190x140.png" alt="Petersen honors Italian automotive designer"/></a>
										    											    	<h7><a href="https://beverlypress.com/2021/03/petersen-honors-italian-automotive-designer/">Petersen honors Italian automotive designer</a></h7>
										    	<span class="post_attribute">March 25, 2021</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2021/03/the-petersen-approaches-starting-line-for-reopening/" title="The Petersen approaches starting line for reopening"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2021/03/Petersen.Reopening.3.25-190x140.png" alt="The Petersen approaches starting line for reopening"/></a>
										    											    	<h7><a href="https://beverlypress.com/2021/03/the-petersen-approaches-starting-line-for-reopening/">The Petersen approaches starting line for reopening</a></h7>
										    	<span class="post_attribute">March 18, 2021</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2021/03/unbox-petersen-museum-on-youtube/" title="Unbox Petersen Museum on YouTube"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2021/03/i-PetersenMuseumYouTube-190x140.png" alt="Unbox Petersen Museum on YouTube"/></a>
										    											    	<h7><a href="https://beverlypress.com/2021/03/unbox-petersen-museum-on-youtube/">Unbox Petersen Museum on YouTube</a></h7>
										    	<span class="post_attribute">March 4, 2021</span>
											</li>
										  										    <li>
										    											    	<h7><a href="https://beverlypress.com/2021/02/take-a-behind-the-scenes-look-at-a-presidential-limo-with-the-petersen/">Take a behind-the-scenes look at a presidential limo with the Petersen</a></h7>
										    	<span class="post_attribute">February 25, 2021</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2020/12/the-petersen-offers-inspiring-virtual-school-tours/" title="The Petersen offers inspiring virtual school tours"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2020/12/i-Petersen-190x140.png" alt="The Petersen offers inspiring virtual school tours"/></a>
										    											    	<h7><a href="https://beverlypress.com/2020/12/the-petersen-offers-inspiring-virtual-school-tours/">The Petersen offers inspiring virtual school tours</a></h7>
										    	<span class="post_attribute">December 3, 2020</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2020/10/petersen-automotive-museum-raises-record-1-2m/" title="Petersen Automotive Museum raises record $1.2M"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2020/10/i-Petersen.GalaSuccess-MGA-190x140.png" alt="Petersen Automotive Museum raises record $1.2M"/></a>
										    											    	<h7><a href="https://beverlypress.com/2020/10/petersen-automotive-museum-raises-record-1-2m/">Petersen Automotive Museum raises record $1.2M</a></h7>
										    	<span class="post_attribute">October 8, 2020</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2020/07/car-enthusiasts-prepare-for-petersens-car-week/" title="Car enthusiasts prepare for Petersen’s Car Week"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2020/07/Petersen.Future-Collector-Car-Show-190x140.jpg" alt="Car enthusiasts prepare for Petersen’s Car Week"/></a>
										    											    	<h7><a href="https://beverlypress.com/2020/07/car-enthusiasts-prepare-for-petersens-car-week/">Car enthusiasts prepare for Petersen’s Car Week</a></h7>
										    	<span class="post_attribute">July 30, 2020</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2020/07/car-museum-offers-online-resources/" title="Car museum offers online resources"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2020/07/p-Petersen.July_.23.20-190x140.jpg" alt="Car museum offers online resources"/></a>
										    											    	<h7><a href="https://beverlypress.com/2020/07/car-museum-offers-online-resources/">Car museum offers online resources</a></h7>
										    	<span class="post_attribute">July 23, 2020</span>
											</li>
										  										    <li>
										    											    		<a href="https://beverlypress.com/2020/07/petersen-team-ups-with-new-partners-for-car-week/" title="Petersen team ups with new partners for car week"><img class="carousel_thumb" src="https://beverlypress.com/wp-content/uploads/2020/06/p-Petersen.Exterior-190x140.jpg" alt="Petersen team ups with new partners for car week"/></a>
										    											    	<h7><a href="https://beverlypress.com/2020/07/petersen-team-ups-with-new-partners-for-car-week/">Petersen team ups with new partners for car week</a></h7>
										    	<span class="post_attribute">July 16, 2020</span>
											</li>
										  									  
								  		</ul>
								    </div>
								    <br class="clear"/><br/>
																
										
								<br class="clear"/>
								 
<div class="comment_inner">
		
	<h5 class="header_line subtitle"><span>0 Comment</span></h5>
	
	  
	
	
		
	<br class="clear"/>
</div>
									<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/03/breakfast-club-cruise-in/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://beverlypress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='77946' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7ac505c9f8" /></p><input type="hidden" id="ak_js" name="ak_js" value="164"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>								<br class="clear"/>
								
															</div>
						</div>
					</div>
				</div>
					<div class="sidebar_wrapper fade-in animated4">
						<div class="sidebar">
							
							<div class="content">
							
								<ul class="sidebar_widget">
									<li>
									
										<!--homepage ad-->

	

																			
									</li>
									<li id="text-13" class="widget widget_text">			<div class="textwidget"><a href="https://issuu.com/beverlypress/docs/2018-dining-and-entertainment-reduc?e=2980394/64636023" target="_blank" rel="noopener"><img src="https://beverlypress.com/wp-content/uploads/2016/01/footer-cover-2018.png" alt="footer-cover-2018" width="300" height="auto" class="aligncenter size-full wp-image-52592" /></a></div>
		</li>
<li id="custom_social_counter-2" class="widget Custom_Social_Counter"><h2 class="widgettitle">Socialize</h2>		    <div class="social_profile">
		    			        		        <div class="profile">
		        	<a class="social_icon twitter" href="http://twitter.com/BeverlyPress">
		        		<img src="https://beverlypress.com/wp-content/themes/jupiter/images/social_twitter_light.png" alt="" class="social"/>
		        	</a>
		        	<div class="counter">
		        		<h4>2,276</h4>
		        		<span class="count">followers</span>
		        	</div>
		        	<a class="button" href="http://twitter.com/BeverlyPress">Follow</a>
		        </div>
		        		        		    </div>
</li>
<li id="custom_popular_posts-2" class="widget Custom_Popular_Posts"><h2 class="widgettitle">Popular Posts</h2><ul class="posts blog"><li><a href="https://beverlypress.com/2014/07/driver-of-stolen-tesla-dies-after-crash-on-la-brea/"><img class="alignleft frame" src="https://beverlypress.com/wp-content/uploads/2014/07/TeslaCrash.gif" alt="" /></a><strong class="title"><a href="https://beverlypress.com/2014/07/driver-of-stolen-tesla-dies-after-crash-on-la-brea/">Driver of stolen Tesla dies after crash on La Brea</a></strong><br/><span class="post_attribute">Jul 10, 2014</span></li><li><a href="https://beverlypress.com/2014/01/protestors-rally-to-%e2%80%98save-the-halls%e2%80%99/"><img class="alignleft frame" src="https://beverlypress.com/wp-content/uploads/2013/12/GreatHallLongHall1.gif" alt="" /></a><strong class="title"><a href="https://beverlypress.com/2014/01/protestors-rally-to-%e2%80%98save-the-halls%e2%80%99/">Protestors rally to ‘save the halls’</a></strong><br/><span class="post_attribute">Jan 2, 2014</span></li><li><a href="https://beverlypress.com/2013/08/o%e2%80%99farrell-settling-in-as-hollywood-councilman/"><img class="alignleft frame" src="https://beverlypress.com/wp-content/uploads/2013/07/MitchOFarrell.gif" alt="" /></a><strong class="title"><a href="https://beverlypress.com/2013/08/o%e2%80%99farrell-settling-in-as-hollywood-councilman/">O’Farrell settling in as Hollywood councilman</a></strong><br/><span class="post_attribute">Aug 1, 2013</span></li><li><a href="https://beverlypress.com/2013/12/council-votes-to-demolish-great-halllong-hall/"><img class="alignleft frame" src="https://beverlypress.com/wp-content/uploads/2013/12/GreatHallLongHall.gif" alt="" /></a><strong class="title"><a href="https://beverlypress.com/2013/12/council-votes-to-demolish-great-halllong-hall/">Council votes to demolish Great Hall/Long Hall</a></strong><br/><span class="post_attribute">Dec 5, 2013</span></li><li><a href="https://beverlypress.com/2015/08/war-of-words-waged-with-l-a-animal-services/"><img class="alignleft frame" src="https://beverlypress.com/wp-content/uploads/2015/08/p-MayorsHouseProtest1-190x140.gif" alt="" /></a><strong class="title"><a href="https://beverlypress.com/2015/08/war-of-words-waged-with-l-a-animal-services/">War of words waged with L.A. Animal Services</a></strong><br/><span class="post_attribute">Aug 5, 2015</span></li></ul></li>
								</ul>
								
							</div>
						
						</div>
						<br class="clear"/>
					
						<div class="sidebar_bottom"></div>
					</div>
					
				</div>
				<!-- End main content -->
				
				<br class="clear"/>
			</div>
			
			<div class="bottom"></div>
			
		</div>
		<!-- End content -->

		

	
    <!-- Begin footer -->
    <div class="footer_wrapper">
    	    <div id="footer">
	    	<ul class="sidebar_widget">
	    		<li id="text-9" class="widget widget_text">			<div class="textwidget"><img src="https://beverlypress.com/wp-content/uploads/2016/01/park-labrea-news-beverly-press-hi-1.png" width="250px" height="auto" />
<br><br>
<em>Serving the Park Labrea, Miracle Mile, Hancock Park and West Hollywood communities since 1946.</em></div>
		</li>
<li id="text-8" class="widget widget_text">			<div class="textwidget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_29888"><a href="https://issuu.com/beverlypress/docs/see-sip-savor-2019?fr=sY2RlNTI5MTQ3Ng" target="_blank" rel="noopener"><img src="https://beverlypress.com/wp-content/uploads/2019/09/see-sip-savor-footer.png" width="300" height="auto" class="aligncenter size-full wp-image-52592" /></a></div></div></div>
		</li>
<li id="text-4" class="widget widget_text">			<div class="textwidget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_29890"><a href="http://issuu.com/beverlypress/docs/our-people-our-places-70th-annivers/1" target="_blank" rel="noopener"><img src="https://beverlypress.com/wp-content/uploads/2016/01/bottom-70th-ad.png" alt="bottom-70th-ad" width="460" height="316" class="aligncenter size-full wp-image-32671" /></a></div></div></div>
		</li>
	    	</ul>
	    	
	    	<br class="clear"/><br/><br/>
	    
	    </div>
	    
    <div id="copyright">
    	<div class="standard_wrapper wide">
    		<div id="copyright_left">
    	    © 2016 Park Labrea News and Beverly Press, All Rights Reserved.    		</div>
    		<a id="toTop">Back to top</a>
    	</div>
    </div>
    
    </div>
    <!-- End footer -->

</div>
<!-- End template wrapper -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4622650-25', 'auto');
  ga('send', 'pageview');

</script>
<div style="display: none;"><div id="boxzilla-box-29155-content"><p><a href="https://issuu.com/beverlypress/docs/see-sip-savor-2019?fr=sY2RlNTI5MTQ3Ng" target="_blank"><img class="alignnone size-full wp-image-61989" src="https://beverlypress.com/wp-content/uploads/2019/09/see-sip-savor-footer.png" alt="see-sip-savor-footer" width="336" height="358" /></a></p>
</div></div><link rel='stylesheet' id='fac-fa-css'  href='https://beverlypress.com/wp-content/plugins/agp-font-awesome-collection/vendor/agp/agp-fontawesome/css/font-awesome.min.css?ver=67ec925be406469c010e4e6f6a53f49d' type='text/css' media='all' />
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/fancybox/jquery.fancybox.pack.js?ver=2.3' id='fancybox/jquery.fancybox.pack.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/hint.js?ver=2.3' id='hint.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/jquery.tipsy.js?ver=2.3' id='jquery.tipsy.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/browser.js?ver=2.3' id='browser.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/flexslider/jquery.flexslider-min.js?ver=2.3' id='flexslider/jquery.flexslider-min.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/jwplayer.js?ver=2.3' id='jwplayer.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/waypoints.min.js?ver=2.3' id='waypoints.min.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/mediaelement/mediaelement-and-player.min.js?ver=2.3' id='mediaelement/mediaelement-and-player.min.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/jquery.touchwipe.1.1.1.js?ver=2.3' id='jquery.touchwipe.1.1.1.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/jquery.ppflip.js?ver=2.3' id='jquery.ppflip.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/jquery.swipebox.min.js?ver=2.3' id='jquery.swipebox.min.js-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/themes/jupiter/js/custom.js?ver=2.3' id='custom.js-js'></script>
<script type='text/javascript' id='boxzilla-js-extra'>
/* <![CDATA[ */
var boxzilla_options = {"testMode":"","boxes":[{"id":29155,"icon":"&times;","content":"","css":{"background_color":"#ffffff","color":"#0c0c0c","width":400,"border_color":"#0a0a0a","border_width":10,"border_style":"solid","position":"bottom-left"},"trigger":{"method":"percentage","value":40},"animation":"slide","cookie":{"triggered":0,"dismissed":48},"rehide":true,"position":"bottom-left","screenWidthCondition":null,"closable":true,"post":{"id":29155,"title":"70th Anniversary Sign Up","slug":"70th-anniversary-sign"}}]};
/* ]]> */
</script>
<script type='text/javascript' src='https://beverlypress.com/wp-content/plugins/boxzilla/assets/js/script.min.js?ver=3.2.24' id='boxzilla-js'></script>
<script type='text/javascript' src='https://beverlypress.com/wp-includes/js/wp-embed.min.js?ver=67ec925be406469c010e4e6f6a53f49d' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://beverlypress.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/postscribe/2.0.8/postscribe.min.js"></script>

</body>
</html>

<!-- Dynamic page generated in 0.990 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-03-26 19:11:47 -->

<!-- Compression = gzip -->